The Reef Tank banner
1 - 10 of 10 Posts

·
Registered
Joined
·
96 Posts
Discussion Starter · #1 ·
I'm having issues with slime algae. I added powerheads, cut down on food. have been syphoning from get go. On top of that i think im having a diatom bloom. My tank looks like crap. It's not bothering the fish or corals any but it's driving me nuts! What's the best way to tackle these problems? Or do I leave it and it'll go away? What will eat the cyno as far as CUC? here's some pics


:help::help::help::help:
 

·
Underwater Demolitions
Joined
·
11,720 Posts
Your monti cap looks a little bleached. :-(

What do you have going for lights and filtration? That makes a big difference in how much uglies you get.

New tanks are the hardest. Its a shame. It would be great if they started easy and got progressively harder, like in school.
 

·
Chasing Stability
Joined
·
9,343 Posts
Blow out your rocks with a turkey baster, let it all settle to the substrate, then siphon it out while siphoning your sandbed. You could rubberband a toothbrush to the end of your siphon and brush it off of the rocks into your siphon tube.
 

·
I've got the REEF rash!
Joined
·
64,175 Posts
There's probably your problem.Most LFS don't change their filters enough and only give you RO filter water.You need to buy a RO/DI filter to make SW and make up water.And you really need to look into more light and a good skimmer.:2cents:
 
1 - 10 of 10 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top