The Reef Tank banner
1 - 20 of 42 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
Hi,

I recently started a 25 gallon salt water tank about three weeks ago. I have a frog span anemone, 3 types of polyps, and some kind of sea fan. my parameters are all at perfect (says the 2 aquariums that are taking care of my tank) but the tank is getting covered with brown stuff, even the sand and it seems to be taking over. WHAT SHOULD I DO IN THIS SITUATION? ANYTHING THAT CAN STOP IT?

EQUIPMENT: I have a prism (redsea) skimmer, a fountain filter, T5 light set up (day, Blue, and Blue LED) (Brand:Seahorse).

I will be getting my two mated clown fish (tiny) and my rose bubble anemone in one week if my parameter are ok. IS THIS OK??
 

·
Registered
Joined
·
331 Posts
You are moving way to fast. No tank under a year old should even have anemones. And 3 weeks is probably just the end of the cycle or there is a good chance the cycle isnt even over. I would take the anenome out and dont even get the second one. Keep testing your water and wait for all the spikes to go away and for the parameters to be stable then you can add the two clowns but thats all i would add and stay with them for a while before adding anything else. The anenome you have in there now has a good chance of dying.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #4 ·
Thanks for the reply,

I was not aware of the one year "rule" I have been getting different views from all the aquiariums where i live (5) and they are all saying that anemones are ok...fish are not..yet...but as always i try and get another opinion. I bought the anemone out of curiosity and the all said it was fine. I do a test every 3-4 days so roughly about twice a week since its cycling and have had no spikes YET.

what about the brown stuff in my tank? its taking everything over?

Also what about the Polyps? i was also advised these were ok. is it true?
 

·
Registered
Joined
·
331 Posts
Totally my bad didnt even look at the name just saw the word anenome and 3 weeks and jumped to a conclusion. Should've looked harder and not been listening to sportscenter while reading. Sorry
 

·
Registered
Joined
·
5,539 Posts
It's alright, we all make mistakes!

An that frog spawn is just fine for having in your tank. If it is opening up, then I wouldn't take it out.

Have you tested your water at all? Or heard the results? Its not that anything is wrong, it that we all like to get a basis of what the tank is like for future issues.

A pic is always welcomed too! :thumbup:
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #9 ·
Its cool....So its a no go on the anemone next week?? and is the Frog Spawn ok??

And thanks....Im new to this whole thing and living in a foreign country doesnt help lol
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #10 ·
How do i post a pic???

Yes the frog spawn has completely opened up. I think its due to the lighting i have.

Also i check my water every 3-4 days since its cycling....just very cautious. everything has been perfect every test.
 

·
Registered
Joined
·
79 Posts
Hi,

I recently started a 25 gallon salt water tank about three weeks ago. I have a frog span anemone, 3 types of polyps, and some kind of sea fan. my parameters are all at perfect (says the 2 aquariums that are taking care of my tank) but the tank is getting covered with brown stuff, even the sand and it seems to be taking over. WHAT SHOULD I DO IN THIS SITUATION? ANYTHING THAT CAN STOP IT?

EQUIPMENT: I have a prism (redsea) skimmer, a fountain filter, T5 light set up (day, Blue, and Blue LED) (Brand:Seahorse).

I will be getting my two mated clown fish (tiny) and my rose bubble anemone in one week if my parameter are ok. IS THIS OK??
with your tank being only 3 weeks old what you are getting is diatoms,(brown)they will go away with time as your tank matures.
 

·
Registered
Joined
·
5,539 Posts
How do i post a pic???

Yes the frog spawn has completely opened up. I think its due to the lighting i have.

Also i check my water every 3-4 days since its cycling....just very cautious. everything has been perfect every test.
You go to the gallery and upload a picture, then copy the image URL, not the site, and click on the little mountain and sun image in the post, then paste image URL there.
 

·
Registered
Joined
·
49 Posts
Discussion Starter · #17 ·
Also are polyps ok?

Also i found some pink worms in a rock i was going to put in my tank but i decided not to since i dont know if they are good or not...opinions??
 
1 - 20 of 42 Posts
Top