The Reef Tank banner

1 - 12 of 12 Posts

·
Registered
Joined
·
335 Posts
Discussion Starter · #1 ·
Got home today, and my DE 70 watt bulb wont fire anymore. It flickers like it's trying to fire, but wont light up completely. I've only had it running about 2 months now :-( There appears to be two flat disks within the bulb connected to wires. One of the disks is broken and the particles are sitting on the bottom of the bulb. Any ideas? Thanks.

Chad
 

·
Registered
Joined
·
1,256 Posts
I really need to stop scanning so fast.... Im not familiar with the internal structure of DE bulbs. I would assume that the disc has something to do with it. Do you have another bulb to compare it to?
 

·
Registered
Joined
·
335 Posts
Discussion Starter · #4 ·
It is a 70 watt aromat ballast. The whole kit was from AquaBuys. It has fired just fine for the past two months so I'm worried about the lack of firing now. My light was actually on a timer, so it has probably been flickering all day until I got home. I would assume if it was going to light it would have. Hope this helps.....and I don't have another bulb to compare.

Chad
 

·
Registered
Joined
·
6,317 Posts
im not familiar with mh, but it sounds like its just blown. particles rolling around in the bottom arent good for any bulb, sounds like it popped the filament.
 

·
Registered
Joined
·
1,256 Posts
hmm... yeah, if you came home to it flickering Id say theres a definate problem.

Anyone else have DE bulbs so we can help out with this problem?
 

·
Premium Member
Joined
·
7,654 Posts
It sounds as if the bulb is shot. The "disks" are there to keep the arc tube centered in the glass envelope. Even if the bulb was still firing; it would be quite dangerous to run it with the arc tube touching or too close to the side of the envelope; and may result in a fire.
 

·
Registered
Joined
·
335 Posts
Discussion Starter · #9 ·
Well Crap...I just got the bulb! Is it appropriate for me to mention it to the retailer, or is that just something I have to deal with and buy a new one? I followed all the directions and have been very careful with it. Wonder why it burnt out. :-(

Chad
 

·
Administrator
Joined
·
34,435 Posts
i believe you can get 70w MH bulbs from HD. they are not the right K to be usefull for lighting the tank, but i think one lying around to test the ballast would be a good thing. i would try another bulb to double check that it is not the ballast.

G~
 

·
Registered
Joined
·
335 Posts
Discussion Starter · #12 ·
Yeah I was looking more at the bulb tonight. It appears a big chunk is missing from one of the inside filament pieces.

Any possibilty the bulb manufacturer can do anything...it shouldn't burn out after 2 months? I guess I might just have to bite the bullet and buy a new one.

Chad
 
1 - 12 of 12 Posts
Top