The Reef Tank banner
algae issues
1-6 of 6 Results
  1. General Reef Discussion
    My tank is circa 2.75 years old All fish and corals doing great but I have a problem with cyanobacteria and diatoms on the sand No issues with nitrate and phosphate readings so where am going wrong? RO/DI water output reading is nil; confused!!!
  2. General Reef Discussion
    Hello, this is would be my second post right after my introduction. This might be a bit long so here I go. So...I have had my tank for about 1 year now. (specs at bottom.) The tank did great for about 6 months until it took a dive in the last 3 months. I had a birds nest that turned completly...
  3. General Reef Discussion
    My tank is about a month old right now and I am have bad algae issues. The algae is green and is covering my entire glass(and appears to be starting to cover my live rock ans substrate some). I can use my mag float and wipe it off and it is back within about an hour or two(not completely but a...
  4. Pests, Hitchhikers, and Diseases
    Ok, I found this growing in a few places on my live rocks. I've had my rocks a while and never had anything growing out of them so I'm assuming that this came as a hitchhiker on a snail shell or some coral... Its not really a problem or at least not at the moment, I'm just making sure its not...
  5. The THINK Tank
    I have started developing a hair algae issue. Not 100% sure on the cause. I had a starfish die around a month before the algae started, and I pulled him out, but about half of him had necrotised before I did. The algae seemed to coincide with switching my 'fuge over to an opposite light...
  6. Rochester Minnesota Marine Aquarium Club (RMMAC)
    i am having some purple and green algae problems please help i have started feeding only like every 3 days a 1\4 cube of brine to 3 damsels i few have a crabs and a blue knuckle with about close tp 15 lbs of lr and in a 14 gal bio cube oh and some brown and green polyups please help i am also...
1-6 of 6 Results
Top